Search the Community: Showing results for tags 'chevrolet'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Ancient Clan News
  • TV
  • Science & Technology
  • News Column
  • Animation
  • Games
  • Movies
  • Articles
  • TV Copy

Categories

  • Records

Forums

  • Ancient Clan
    • News & Announcements
  • Discussion
    • Random
    • Games
    • Movies, TV & Books
    • Anime / Animation / Manga / Comics
    • Science & Technology
  • Archives
    • Archives - Forums

Blogs

  • Sledge's Blog
  • Blog DeathscytheX
  • thoughtlings
  • Blog Sabe
  • Blog Godgrave
  • Blog Samara
  • Blog Kite
  • Blog Myk JL
  • Recipes
  • The A Word
  • The F Word
  • Snack Reviews
  • Battlefield 4 Videos

Calendars

  • Community Calendar

Group


Biography


Location


Interests


Occupation


Favorite Anime


Favorite Game


Favorite Movie


Favorite Book


Currently Watching


Currently Playing


Currently Reading

Found 6 results

  1. When I first got the blazer I had a huge number of issues with it, that thankfully, I was able to get fixed at the dealership for free within the first couple months of buying it. Of course there have been a variety of issues since then that I've had to take care of like a ball joint, alignment, oil leak, front and rear shocks, back brakes, front brakes. At least I've been able to do the brake jobs myself, but just the other day my emergency/parking brakes seized up on my back rotors. F*ck me. Most of the problem was in the back left wheel, I couldn't even get the damn rotor off. The parking brake almost welded itself to it with a layer of rust and a broken clip. You never want to change a rotor without changing the brake pads at the same time, so even tho it didn't need new brake pads I had to put new ones on along with the rotors. Because I couldn't get the rotor off, I broke down and called the local Midas and they took care of it for me. Hundreds of dollars later, its all fixed and safe again. New rotors, pads and e-brakes. And of course the new shit all makes pretty much the same noises, but thats due to the massive amount of rust from the back plate which is located about 3 centimeters from the spinning rotor. I would rip the fucker off and say to hell with the noise, but its safer to leave it on so nothing kicks up from a tire and nicks the rotor. So unless the noise eventually goes away, I'll probably be stuck with a squeaky, rattling blazer from now on. *dies* x_x
  2. This past weekend screwed us. While driving down the road the Blazer died. It completely stalled out 5 minutes from the house. We had to get it towed. There was a fuel leak that had to be fixed and the spark plugs, wires, distributor cap all had to be replaced.
  3. Well, I did the oil change for the Blazer for the first time last Sunday (09-20-2009). I had to buy an oil filter wrench because my grip wrench would not budge that f*cking oil filter no matter how hard I tried. What a pain in my ass that was. Everything went well, but then on monday I noticed a weird humming noise and a stiffness to the steering wheel. Afraid I f*cked something up, I checked all my fluids. But no, it wasn't the oil. My power steering fluid was out. WTF. So I hit the gas station down the road from work, put some power steering fluid in and got home with no problem. I had to to do this a couple of times. I ended up getting some power steering stop leak at NAPA. It seemed to have stopped the leak thursday night. But! I started driving to work friday and the steering gave out completely. I tried putting my fluid in, but the car vomited it all over the road. As of today, I removed the air filter cabin and the front left headlight. It seems that the power steering fluid is leaking from a metal joint that connects to the ps cooler. I'm trying to put a hose over top of the broken section of pipe and clamp it down to fix the leak. I should be finished with it tomorrow, rain permitting. If it doesn't work, I might have to cut that section of pipe off and replace it with a high pressure hose... I'm just hoping that that is the only place it is leaking from. And I have to say this... what a horrible f*cking design flaw. With the way the headlight is positioned, the excess rain water or salty water during the winter that hits in that crack between the headlight and the hood would drip down the back of the headlight and rust the shit out of this metal joint. Why in the hell would someone design something to be rusted out like that? Its like it was made to break.
  4. We come to the conclusion that we will sell the Blazer. We'll end up taking a loss on the loan, but the vehicle's constant maintenance is not worth it. At the current rate of random repairs, we'll actually loose more money keeping the truck than taking the initial loss from a trade in. We're going to look into getting a full or mid size 4 door 4 cylinder sedan. 4x4 is a damn nice feature, but the maintenance and cost is pure hell.
  5. A couple weeks ago the Blazer's service engine soon light came on. I went to Advance Auto Parts and used one of their scanners to find out I had a 'Coolant below thermostat threshold' error code. Basically, my coolant needed to be replaced and also my thermostat, then possibly the coolant temperature sensor. A couple days later I went to Valvoline instant oil change and had them do a coolant flush and also replace the serpentine belt. The serp belt I could have done myself, but the guy told me it was a lifetime warranty and they'll replace it free of charge whenever it starts showing alot of wear, so I figured it would be a good deal because I'll probably need at least one more belt in the next 3-4 years and it saved me the hassle of doing it myself in 30 degree temperatures. The service engine soon light did not go off. I figured it wouldn't, because I would need to replace the thermostat too. Then I got snowed in at my house after a 2 foot snow storm. The car didn't drive anywhere for a couple days. Then on last Sunday, when I was about to go to the local grocery store, I noticed a gas smell. I went to the store and when I came back I noticed the smell still. Turns out the fuel line near the tank started leaking a steady drip of gas. wtf. I didn't have much daylight left so I got under the car, eventually found the pinhole leak, and I proceeded to patch it by placing a piece of cut hose over the hole and then use hose clamps to tighten it down. I must have over tightened it and it started leaking again which pissed me the hell off because at that point I was soaking wet from melting snow/ice (2 feet of melting snow) and pooling gas. After my hands went numb from the cold gas and my arm was killing me because I was awkwardly positioned under the rear differential, I decided to do a really cheap ass move and cut the finger off a nitrile throwaway glove, wrapped it around the pin hole leak, and clamped it down with four zip ties. Its held for a week now with no additional leaking. I was going to take it off and hose clamp it correctly with my piece of hose, but another issue came up. About 3 days ago, the car started making a weird ticking sound after I initially turned the car on. It only lasted for a couple seconds, but I thought it was a bad sign. Turns out it would only do it when the car was sitting for more than a couple hours and the length of time the ticking would last for depended on how cold it was outside. I went back to Advance Auto parts and had them test the alternator and battery because alternators, batteries and starters are all connected to a ticking sound during ignition. The battery and alternator were fine. He couldn't test the started because it would have to be off the engine, and on top of that he said that test would only check to see if the starter can start a car, which is not the problem because the noise only happens after the car is turned on. The guy was pretty knowledgeable and he suggested I do an oil change and use a oil filter with a drain back valve. I guess he meant anti-drain back valve because he told me I probably had oil sludge starting to build up and after the car was sitting for a while, the oil would accumulate in the oil pan and that ticking sound was the thick oil slowly making its way back up to the top of the engine. And that a good oil filter would prevent the oil from draining down completely to the oil pan, which is what an anti-drain back oil filter does. While I was there, I went ahead and bought the thermostat. So, today, I did the oil change on the blazer. I spent the extra money and bought a penzoil full synthetic oil with cleaning additives ($28 for 5 quarts, costly), and I bought a Fram Tough Guard oil filter ($8, $5 more than other filters) which has a 'anti-drain back valve built into it'. I just finished the oil change, my coat is soaked because the tarp I put down over the melting snow/ice was a piece of crap and soaked straight through. Anyway, I started the car up after the oil change and no ticking sound. I'll find out tomorrow morning if the ticking sound is completely gone. I still need to do the thermostat, but my coat is soaked, I need a new tarp and I think I'm going to wait until next weekend when its 40+ degrees again. From what I read, a bad thermostat only causes a little worse fuel efficiency, so I figure if its not damaging the car, it can wait another week.
  6. So after all the work I put into our blazer, and all the money we had to spend on it for random fixes left and right, enough is enough. The transmission starting going over the past couple weeks. From what I saw online, getting a flush would cause more harm than good, but just replacing the filter and a couple quarts of fluid shouldn't cause any problems. So I went to midas and paid them to replace the tranny filter and the fuel filter. They screwed up something by either hitting something too hard when they took the pan off, or they somehow dislodged something, or the transmission was just so bad, that even touching it caused it to screw up even more. After the tranny filter was replaced, it lost the first and second gears and the service engine soon light came on for 2 shift solenoids. Midas offered no help at all afterwords and only told me to take it to a transmission shop. The only way I could drive it was to physically shift it to first, then second, third and then drive... every single time the car came to a stop. So fuck it, we decided to trade it in. We were holding off for a while because we know we owed more than it was worth.. sure as hell the trade in value was pure shit. We did get a good deal at a toyota dealer with zero percent financing for 5 years tho. Yay. We got a new 2010 Toyota Corolla. Pics: http://forums.ancientclan.com/album.php?albumid=62